Performance degradation for Large Projects
Incident Report for Pivotal Tracker
Resolved
Fix for the performance degradation has been deployed and the issue has been resolved.

Apologies for the inconvenience and, as always, please do email tracker@pivotal.io if you need help or have any questions.
Posted 3 months ago. Sep 01, 2017 - 23:42 UTC
Identified
Some customers with large projects may be experiencing performance degradation in Tracker. We've identified the cause and are deploying a fix as soon as possible.

We'll provide updates here, but do email tracker@pivotal.io if we can help meanwhile.
Posted 3 months ago. Sep 01, 2017 - 23:06 UTC