Intermittent 404 errors while using Tracker
Incident Report for Pivotal Tracker
Resolved
All our monitors indicate the problem is resolved and we've received no further reports of 404s since the fix was deployed.

We're sorry you were inconvenienced and we'll examine every aspect of the incident so we can be sure to prevent a similar occurrence in future.

Do write to tracker@pivotal.io if you have questions and thank you for using Tracker.
Posted 9 months ago. Feb 22, 2018 - 16:54 UTC
Monitoring
The 404 and other odd routing issues should now be resolved. Since this was a difficult issue to isolate and fix we won't declare victory immediately, but will continue to monitor to make sure there's nothing remaining to address.

Thank you for your considerable patience while we worked on this, and as always, do email tracker@pivotal.io if there's anything we can help with.
Posted 9 months ago. Feb 21, 2018 - 22:00 UTC
Update
As part of our ongoing efforts to correct the existing production issues in Tracker, we’ll be doing an emergency update within the next hour. This update has the potential to cause downtime in Tracker, though we’ll do our best to avoid that. Thank you for your continued patience and understanding.
Posted 9 months ago. Feb 21, 2018 - 19:46 UTC
Update
We've significantly reduced the rate at which you might see messages forcing you to click Reload. Having done as much as we can to work around the underlying issue, to prevent you from seeing that and losing data, we're continuing to work with the Google Cloud Platform team to get the root cause fixed. We'll keep updating this with any news, as we continue to give this our best attention.

Do email tracker@pivotal.io if we can help or answer any questions meanwhile.
Posted 9 months ago. Feb 20, 2018 - 21:42 UTC
Update
We have deployed a fix that should at least significantly reduce the chances of you seeing a reload message. We're continuing work to identify any remaining instances of forced reloads.

You may continue to see 404's in browser console, even if you don't see the reload message) but those should be harmless.

Apologies for any remaining problems while we continue work. We'll continue until we're confident the issue is fully addressed.
Posted 9 months ago. Feb 20, 2018 - 18:05 UTC
Update
Apologies for the issue escalating and getting worse, including constant 404's for some customers, while we continue to work on a fix. We're fixing and testing simultaneously to try and address this as quickly and safely as possible.
Posted 9 months ago. Feb 20, 2018 - 17:50 UTC
Identified
We've identified a Google Cloud Platform issue that Tracker is not handling correctly, which is resulting in the 404 errors for a small percentage of activities in Tracker. However, unfortunately it does seem that data loss is possible if you see this error before a story is saved. We're working on it urgently and will provide further updates as soon as we have them.
Posted 9 months ago. Feb 20, 2018 - 16:12 UTC
Investigating
We are seeing infrequent and intermittent 404 server errors on actions such as saving a story in Tracker. If you are in a Workspace, you might see the error caused by someone else saving a story in a project in your Workspace. Data doesn't appear to be being lost, so clicking reload on the error message should have no ill effect. However we are actively investigating and will address the issue as soon as possible. Sorry for any inconvenience meanwhile.
Posted 9 months ago. Feb 19, 2018 - 23:55 UTC